Unexpected Symbol ??

General discussion relating to the library modules supplied with the compiler

Moderators: David Barker, Jerry Messina

Post Reply
Wobbles
Posts: 9
Joined: Sun Mar 22, 2015 4:07 pm
Location: Torbay, Devon, u.k.

Unexpected Symbol ??

Post by Wobbles » Sun Apr 05, 2015 1:13 pm

Hi, I'm playing around with swordfish doing the most basic of tasks but i keep getting Symbol not expected errors in the editor

I am only trying little pieces from the documentation for example on page 21 the 'dim PinIsHigh as PORTB.Booleans(0)'

it seems to come up with the message in all sorts of places

Am i missing something thats staring me in the face ?
Me ? No I'm not confused , well I don't think I'm am, well maybe your right !

User avatar
octal
Registered User
Registered User
Posts: 584
Joined: Thu Jan 11, 2007 12:49 pm
Location: Paris IDF
Contact:

Re: Unexpected Symbol ??

Post by octal » Sun Apr 05, 2015 1:42 pm

It's difficult to guess the origin of the problem from your description. Could you, please, post a complete minimalist program showing this behaviour?

PS. When copying/Pasting code from the help file or from web pages, take care to not paste special chars. For example, single quotes can be converted to " ` " char which is not accepted by SF (and is different from real single quote char " ' "). The best is to paste code first to Notepad for example and then copy/paste from notepad to SF IDE.

User avatar
David Barker
Swordfish Developer
Posts: 1194
Joined: Tue Oct 03, 2006 7:01 pm
Location: Saltburn by the Sea, UK
Contact:

Re: Unexpected Symbol ??

Post by David Barker » Wed Apr 08, 2015 9:51 am

As octal has mentioned, we need to see some code in order to reproduce the error here.

Post Reply